问题

安装centos7 之后一直用自带的git,在提交的时候总是出现git版本太低的提示,于是就想了办法去更新git, 百度看了很多教程,都是什么先卸载再重新安装,卸载之前还需要备份一份配置文件,看了很多感觉非常麻烦,于是就在Linux网站中看到了一个最正确的更新及安装方式。以下是安装过程。

解决

配置存储库

在这之前,我们需要在root权限下才可以进一步操作。

su root

启用Wandisco GIT存储库 启用存储库需要在/etc/yum.repos.d/目录中命名的新yum存储库配置文件

vim /etc/yum.repos.d/wandisco-git.repo

添加以下字段,ESC,然后:输入wq保存退出。

[wandisco-git]
name=Wandisco GIT Repository
baseurl=http://opensource.wandisco.com/centos/7/git/$basearch/
enabled=1
gpgcheck=1
gpgkey=http://opensource.wandisco.com/RPM-GPG-KEY-WANdisco

使用以下命名了导入存储库GPG密钥

sudo rpm --import http://opensource.wandisco.com/RPM-GPG-KEY-WANdisco
``` 

### 安装

``` bash
yum install git

完成之后验证一下

git --version

输出

git version 2.18.0

参考原文:https://blog.csdn.net/qq_39478237/article/details/85704412